# CVE-2000-0725: Zope does not properly restrict access to the getRoles method

> Users with DTML editing privileges can escalate their access by modifying role lists, potentially gaining unauthorized administrative control.

- **Severity:** High 7.2 (`AV:L/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2000
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-9cmq-pj6p-hgwf, PYSEC-2026-757

## What is CVE-2000-0725?

CVE-2000-0725 is a high-severity vulnerability in n/a, published on 13 Oct 2000. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Zope before 2.2.1 does not properly restrict access to the getRoles method, which allows users who can edit DTML to add or modify roles by modifying the roles list that is included in a request.

## Which versions are affected by CVE-2000-0725?

3 open source packages ship an affected version, including zope. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope` | PyPI | All versions | 2.2.1 |
| `zope` | PyPI | All versions | 2.2.1 |
| `zope` | PyPI | All versions | 2.2.1 |

Products: Zope Zope.

## How do I fix CVE-2000-0725?

Upgrade zope to 2.2.1 or later.

## Is CVE-2000-0725 being exploited?

There is no known exploitation of CVE-2000-0725 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2000-0062](https://insights.sbomify.com/CVE-2000-0062/): Zope DTML implementation Improper Authentication (critical 10.0)
- [CVE-2021-32674](https://insights.sbomify.com/CVE-2021-32674/): Remote Code Execution via traversal in TAL expressions (high 8.8)
- [CVE-2000-1211](https://insights.sbomify.com/CVE-2000-1211/): Zope does not properly perform security registration for legacy names (high 7.5)
- [CVE-2002-0170](https://insights.sbomify.com/CVE-2002-0170/): Zope does not properly verify the access for objects with proxy roles (high 7.5)
- [CVE-2002-0688](https://insights.sbomify.com/CVE-2002-0688/): ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2000-0725 and fix it if it is affected.

What it is: CVE-2000-0725 is a high-severity vulnerability in n/a, published on 13 Oct 2000. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2000-0725 in the wild and no public exploit code.

Affected packages and fixed versions:
- zope (PyPI): affected all versions; fixed in 2.2.1
- zope (PyPI): affected all versions; fixed in 2.2.1
- zope (PyPI): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2000-0725/ (Markdown: https://insights.sbomify.com/CVE-2000-0725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2000-0725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2000-0725
- OSV: https://osv.dev/vulnerability/CVE-2000-0725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2000-0725/
Summaries are generated and may contain mistakes; the official description above is the record.
