# CVE-2001-0590: Apache Tomcat Allows Source Disclosure

> Remote attackers can read arbitrary JSP source code by sending malformed URLs without HTTP protocol specifications, exposing sensitive application logic.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2002
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-x445-mmpw-7r4f

## What is CVE-2001-0590?

CVE-2001-0590 is a medium-severity vulnerability in Apache Tomcat, published on 9 Mar 2002. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Software Foundation Tomcat Servlet prior to 3.2.2 allows a remote attacker to read the source code to arbitrary 'jsp' files via a malformed URL request which does not end with an HTTP protocol specification (i.e. HTTP/1.0).

## Which versions are affected by CVE-2001-0590?

2 open source packages ship an affected version, including org.apache.tomcat:tomcat-servlet-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat-servlet-api` | Maven | All versions | 3.2.2 |
| `org.apache.tomcat:tomcat-servlet-api` | Maven | All versions | 3.2.2 |

Products: Apache Tomcat.

## How do I fix CVE-2001-0590?

Upgrade org.apache.tomcat:tomcat-servlet-api to 3.2.2 or later.

## Is CVE-2001-0590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2001-0590 exists.

Public exploit code:

- Apache Tomcat 3.0 - Directory Traversal (exploitdb)

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2001-0590 and fix it if it is affected.

What it is: CVE-2001-0590 is a medium-severity vulnerability in Apache Tomcat, published on 9 Mar 2002. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2001-0590 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat-servlet-api (Maven): affected all versions; fixed in 3.2.2
- org.apache.tomcat:tomcat-servlet-api (Maven): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2001-0590/ (Markdown: https://insights.sbomify.com/CVE-2001-0590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2001-0590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2001-0590
- OSV: https://osv.dev/vulnerability/CVE-2001-0590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2001-0590/
Summaries are generated and may contain mistakes; the official description above is the record.
