{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2001-0995 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2001-0995 yet. Limit exposure of the affected software until one is available.","what":"CVE-2001-0995 is a high-severity missing authorization vulnerability in n/a, published on 9 Mar 2002. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2001-0995 and fix it if it is affected.\n\nWhat it is: CVE-2001-0995 is a high-severity missing authorization vulnerability in n/a, published on 9 Mar 2002. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2001-0995 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2001-0995/ (Markdown: https://insights.sbomify.com/CVE-2001-0995/index.md)","id":"CVE-2001-0995","markdown":"https://insights.sbomify.com/CVE-2001-0995/index.md","name":"CVE-2001-0995","record":{"aliases":["GHSA-h9r3-qjcq-v657"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHProjekt web application","requires_auth":"low_privilege","summary":"Remote attackers can perform actions as other users by modifying ID numbers in HTTP requests, requiring an upgrade to version 2.4a or later.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpprojekt","vendor":"phpprojekt"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"PHProjekt before 2.4a allows remote attackers to perform actions as other PHProjekt users by modifying the ID number in an HTTP request to PHProjekt CGI programs.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Missing authorization in n/a","id":"CVE-2001-0995","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2001"},"n_packages":0,"n_references":4,"next":{"headline":"Other in n/a","id":"CVE-2001-0996"},"packages":[],"prev":{"headline":"Denial of service in n/a","id":"CVE-2001-0994"},"products":["n/a"],"published":"2002-03-09","related":[{"cvss_score":7.5,"headline":"Code injection in n/a","id":"CVE-2002-0451","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2007-1638","kev_date_added":null,"published":"2007-03-23"},{"cvss_score":5.1,"headline":"File upload in n/a","id":"CVE-2006-4609","kev_date_added":null,"published":"2006-09-07"},{"cvss_score":4.6,"headline":"File upload in n/a","id":"CVE-2007-1639","kev_date_added":null,"published":"2007-03-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-08","vendors":["n/a"]},"summary":"Remote attackers can perform actions as other users by modifying ID numbers in HTTP requests, requiring an upgrade to version 2.4a or later.","url":"https://insights.sbomify.com/CVE-2001-0995/"}