CVE-2002-0170 Zope does not properly verify the access for objects with proxy roles

High 7.5 Published Updated

Attackers with low privileges can bypass access controls to read restricted documents in Zope web applications.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2002-0170?

CVE-2002-0170 is a high-severity missing authorization vulnerability in n/a, published on 2 Apr 2003. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

Which versions are affected by CVE-2002-0170?

5 open source packages ship an affected version, including zope. It affects 1 product.

PackageAffectedFixed in
zope PyPIFrom 2.2.02.4.4, 2.5.1
zope PyPIFrom 2.2.02.4.4
zope PyPIFrom 2.2.02.4.4
zope PyPIFrom 2.5.02.5.1
zope PyPIFrom 2.5.02.5.1

Products include Zope Zope.

How do I fix CVE-2002-0170?

Upgrade zope to a fixed version for your release line: 2.4.4 or 2.5.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2002-0170 being exploited?

There is no known exploitation of CVE-2002-0170 in the wild and no public exploit code.

Sources

Also known as GHSA-c3rp-4cjh-cp38, PYSEC-2026-758.

Is CVE-2002-0170 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free