{"answers":{"affected":"5 open source packages ship an affected version, including zope. It affects 1 product.","exploited":"There is no known exploitation of CVE-2002-0170 in the wild and no public exploit code.","fix":"Upgrade zope to a fixed version for your release line: 2.4.4 or 2.5.1.","what":"CVE-2002-0170 is a high-severity missing authorization vulnerability in n/a, published on 2 Apr 2003. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2002-0170 and fix it if it is affected.\n\nWhat it is: CVE-2002-0170 is a high-severity missing authorization vulnerability in n/a, published on 2 Apr 2003. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2002-0170 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zope (PyPI): affected from 2.2.0; fixed in 2.4.4, 2.5.1\n- zope (PyPI): affected from 2.2.0; fixed in 2.4.4\n- zope (PyPI): affected from 2.2.0; fixed in 2.4.4\n- zope (PyPI): affected from 2.5.0; fixed in 2.5.1\n- zope (PyPI): affected from 2.5.0; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2002-0170/ (Markdown: https://insights.sbomify.com/CVE-2002-0170/index.md)","id":"CVE-2002-0170","markdown":"https://insights.sbomify.com/CVE-2002-0170/index.md","name":"CVE-2002-0170","record":{"aliases":["GHSA-c3rp-4cjh-cp38","PYSEC-2026-758"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Zope web application","requires_auth":"low_privilege","summary":"Attackers with low privileges can bypass access controls to read restricted documents in Zope web applications.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"zope","vendor":"zope"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zope does not properly verify the access for objects with proxy roles","id":"CVE-2002-0170","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2002"},"n_packages":5,"n_references":6,"next":{"headline":"Auth bypass in n/a","id":"CVE-2002-0171"},"packages":[{"ecosystem":"PyPI","fixed":["2.4.4","2.5.1"],"introduced":["2.2.0","2.5.0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"PYSEC-2026-758"},{"ecosystem":"PyPI","fixed":["2.4.4"],"introduced":["2.2.0"],"last_affected":[],"package":"zope","purl":null,"source":"GHSA-c3rp-4cjh-cp38"},{"ecosystem":"PyPI","fixed":["2.4.4"],"introduced":["2.2.0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"GHSA-c3rp-4cjh-cp38"},{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["2.5.0"],"last_affected":[],"package":"zope","purl":null,"source":"GHSA-c3rp-4cjh-cp38"},{"ecosystem":"PyPI","fixed":["2.5.1"],"introduced":["2.5.0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"GHSA-c3rp-4cjh-cp38"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2002-0169"},"products":["n/a"],"published":"2003-04-02","related":[{"cvss_score":10,"headline":"Zope DTML implementation Improper Authentication","id":"CVE-2000-0062","kev_date_added":null,"published":"2000-04-18"},{"cvss_score":8.8,"headline":"Remote Code Execution via traversal in TAL expressions","id":"CVE-2021-32674","kev_date_added":null,"published":"2021-06-08"},{"cvss_score":7.5,"headline":"Zope does not properly perform security registration for legacy names","id":"CVE-2000-1211","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions","id":"CVE-2002-0688","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1227","kev_date_added":null,"published":"2002-06-25"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1278","kev_date_added":null,"published":"2002-05-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-08","vendors":["n/a"]},"summary":"Attackers with low privileges can bypass access controls to read restricted documents in Zope web applications.","url":"https://insights.sbomify.com/CVE-2002-0170/"}