# CVE-2002-0170: Zope does not properly verify the access for objects with proxy roles

> Attackers with low privileges can bypass access controls to read restricted documents in Zope web applications.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2003
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-c3rp-4cjh-cp38, PYSEC-2026-758

## What is CVE-2002-0170?

CVE-2002-0170 is a high-severity missing authorization vulnerability in n/a, published on 2 Apr 2003. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.

## Which versions are affected by CVE-2002-0170?

5 open source packages ship an affected version, including zope. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope` | PyPI | From 2.2.0 | 2.4.4, 2.5.1 |
| `zope` | PyPI | From 2.2.0 | 2.4.4 |
| `zope` | PyPI | From 2.2.0 | 2.4.4 |
| `zope` | PyPI | From 2.5.0 | 2.5.1 |
| `zope` | PyPI | From 2.5.0 | 2.5.1 |

Products: Zope Zope.

## How do I fix CVE-2002-0170?

Upgrade zope to a fixed version for your release line: 2.4.4 or 2.5.1.

## Is CVE-2002-0170 being exploited?

There is no known exploitation of CVE-2002-0170 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2000-0062](https://insights.sbomify.com/CVE-2000-0062/): Zope DTML implementation Improper Authentication (critical 10.0)
- [CVE-2021-32674](https://insights.sbomify.com/CVE-2021-32674/): Remote Code Execution via traversal in TAL expressions (high 8.8)
- [CVE-2000-1211](https://insights.sbomify.com/CVE-2000-1211/): Zope does not properly perform security registration for legacy names (high 7.5)
- [CVE-2002-0688](https://insights.sbomify.com/CVE-2002-0688/): ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions (high 7.5)
- [CVE-2001-1227](https://insights.sbomify.com/CVE-2001-1227/): Security feature bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2002-0170 and fix it if it is affected.

What it is: CVE-2002-0170 is a high-severity missing authorization vulnerability in n/a, published on 2 Apr 2003. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2002-0170 in the wild and no public exploit code.

Affected packages and fixed versions:
- zope (PyPI): affected from 2.2.0; fixed in 2.4.4, 2.5.1
- zope (PyPI): affected from 2.2.0; fixed in 2.4.4
- zope (PyPI): affected from 2.2.0; fixed in 2.4.4
- zope (PyPI): affected from 2.5.0; fixed in 2.5.1
- zope (PyPI): affected from 2.5.0; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2002-0170/ (Markdown: https://insights.sbomify.com/CVE-2002-0170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2002-0170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2002-0170
- OSV: https://osv.dev/vulnerability/CVE-2002-0170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2002-0170/
Summaries are generated and may contain mistakes; the official description above is the record.
