CVE-2002-0687 Zope Server vulnerable to DoS via header injection
Untrusted users can shut down the Zope server via specific headers in the web code capability, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2002-0687?
CVE-2002-0687 is a medium-severity denial of service vulnerability in n/a, published on 2 Apr 2003. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers.
Which versions are affected by CVE-2002-0687?
5 open source packages ship an affected version, including zope. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
zope PyPI | From 2.0.0 | 2.4.4b2, 2.5.1b2 |
zope PyPI | From 2.0.0 | 2.4.4b2 |
zope PyPI | From 2.0.0 | 2.4.4b2 |
zope PyPI | From 2.5.0 | 2.5.1b2 |
zope PyPI | From 2.5.0 | 2.5.1b2 |
Products include Zope Zope.
How do I fix CVE-2002-0687?
Upgrade zope to a fixed version for your release line: 2.4.4b2 or 2.5.1b2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2002-0687 being exploited?
There is no known exploitation of CVE-2002-0687 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2000-0062 Zope DTML implementation Improper Authentication
- CVE-2021-32674 Remote Code Execution via traversal in TAL expressions
- CVE-2000-1211 Zope does not properly perform security registration for legacy names
- CVE-2002-0170 Zope does not properly verify the access for objects with proxy roles
- CVE-2002-0688 ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions
Sources
Also known as GHSA-vwrc-g9q6-f675, PYSEC-2026-761.