{"answers":{"affected":"5 open source packages ship an affected version, including zope. It affects 1 product.","exploited":"There is no known exploitation of CVE-2002-0687 in the wild and no public exploit code.","fix":"Upgrade zope to a fixed version for your release line: 2.4.4b2 or 2.5.1b2.","what":"CVE-2002-0687 is a medium-severity denial of service vulnerability in n/a, published on 2 Apr 2003. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2002-0687 and fix it if it is affected.\n\nWhat it is: CVE-2002-0687 is a medium-severity denial of service vulnerability in n/a, published on 2 Apr 2003. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2002-0687 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zope (PyPI): affected from 2.0.0; fixed in 2.4.4b2, 2.5.1b2\n- zope (PyPI): affected from 2.0.0; fixed in 2.4.4b2\n- zope (PyPI): affected from 2.0.0; fixed in 2.4.4b2\n- zope (PyPI): affected from 2.5.0; fixed in 2.5.1b2\n- zope (PyPI): affected from 2.5.0; fixed in 2.5.1b2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2002-0687/ (Markdown: https://insights.sbomify.com/CVE-2002-0687/index.md)","id":"CVE-2002-0687","markdown":"https://insights.sbomify.com/CVE-2002-0687/index.md","name":"CVE-2002-0687","record":{"aliases":["GHSA-vwrc-g9q6-f675","PYSEC-2026-761"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Zope web application","requires_auth":"none","summary":"Untrusted users can shut down the Zope server via specific headers in the web code capability, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"zope","vendor":"zope"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[],"description":"The \"through the web code\" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zope Server vulnerable to DoS via header injection","id":"CVE-2002-0687","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2002"},"n_packages":5,"n_references":5,"next":{"headline":"ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions","id":"CVE-2002-0688"},"packages":[{"ecosystem":"PyPI","fixed":["2.4.4b2","2.5.1b2"],"introduced":["2.0.0","2.5.0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"PYSEC-2026-761"},{"ecosystem":"PyPI","fixed":["2.4.4b2"],"introduced":["2.0.0"],"last_affected":[],"package":"zope","purl":null,"source":"GHSA-vwrc-g9q6-f675"},{"ecosystem":"PyPI","fixed":["2.4.4b2"],"introduced":["2.0.0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"GHSA-vwrc-g9q6-f675"},{"ecosystem":"PyPI","fixed":["2.5.1b2"],"introduced":["2.5.0"],"last_affected":[],"package":"zope","purl":null,"source":"GHSA-vwrc-g9q6-f675"},{"ecosystem":"PyPI","fixed":["2.5.1b2"],"introduced":["2.5.0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"GHSA-vwrc-g9q6-f675"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2002-0686"},"products":["n/a"],"published":"2003-04-02","related":[{"cvss_score":10,"headline":"Zope DTML implementation Improper Authentication","id":"CVE-2000-0062","kev_date_added":null,"published":"2000-04-18"},{"cvss_score":8.8,"headline":"Remote Code Execution via traversal in TAL expressions","id":"CVE-2021-32674","kev_date_added":null,"published":"2021-06-08"},{"cvss_score":7.5,"headline":"Zope does not properly perform security registration for legacy names","id":"CVE-2000-1211","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Zope does not properly verify the access for objects with proxy roles","id":"CVE-2002-0170","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions","id":"CVE-2002-0688","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1227","kev_date_added":null,"published":"2002-06-25"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1278","kev_date_added":null,"published":"2002-05-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-08","vendors":["n/a"]},"summary":"Untrusted users can shut down the Zope server via specific headers in the web code capability, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2002-0687/"}