CVE-2002-1148 Apache Tomcat Source Code Disclosure
Remote attackers can read server source code by directly requesting the default servlet in vulnerable Tomcat versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2002-1148?
CVE-2002-1148 is a medium-severity vulnerability in Apache Tomcat, published on 1 Sep 2004. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The default servlet (org.apache.catalina.servlets.DefaultServlet) in Tomcat 4.0.4 and 4.1.10 and earlier allows remote attackers to read source code for server files via a direct request to the servlet.
Which versions are affected by CVE-2002-1148?
4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 4.0.0 | 4.0.5 |
org.apache.tomcat:tomcat Maven | From 4.0.0 | 4.0.5 |
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.12 |
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.12 |
Products include Apache Tomcat.
How do I fix CVE-2002-1148?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.0.5 or 4.1.12.
Is CVE-2002-1148 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2002-1148 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Apache Tomcat
Sources
Also known as DSA-170, GHSA-jxcv-v856-j5vg.