{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2002-1567 exists.","fix":"Upgrade org.apache.tomcat:tomcat to 4.1.29 or later.","what":"CVE-2002-1567 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 19 Sep 2003. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2002-1567 and fix it if it is affected.\n\nWhat it is: CVE-2002-1567 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 19 Sep 2003. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2002-1567 exists.\n\nAffected packages and fixed versions:\n- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.29\n- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.29\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2002-1567/ (Markdown: https://insights.sbomify.com/CVE-2002-1567/index.md)","id":"CVE-2002-1567","markdown":"https://insights.sbomify.com/CVE-2002-1567/index.md","name":"CVE-2002-1567","record":{"aliases":["GHSA-86fp-jgwm-wgj5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Tomcat","requires_auth":"none","summary":"Remote attackers can execute arbitrary scripts and steal cookies via crafted URLs in Apache Tomcat, requiring user interaction.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"tomcat","vendor":"apache"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Cross-site scripting (XSS) vulnerability in Apache Tomcat 4.1 allows remote attackers to execute arbitrary web script and steal cookies via a URL with encoded newlines followed by a request to a .jsp file whose name contains the script.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2002-08-21","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2002-08-21","kind":"exploitdb","ref":"21734","stars":null,"title":"Apache Tomcat 4.1 - JSP Request Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Apache Tomcat XSS Vulnerability","id":"CVE-2002-1567","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:tomcat","products":["apache:tomcat"],"type":"xss","year":"2002"},"n_packages":2,"n_references":5,"next":{"headline":"Denial of service in n/a","id":"CVE-2002-1568"},"packages":[{"ecosystem":"Maven","fixed":["4.1.29"],"introduced":["4.1.0"],"last_affected":[],"package":"org.apache.tomcat:tomcat","purl":null,"source":"GHSA-86fp-jgwm-wgj5"},{"ecosystem":"Maven","fixed":["4.1.29"],"introduced":["4.1.0"],"last_affected":[],"package":"org.apache.tomcat:tomcat","purl":"pkg:maven/org.apache.tomcat/tomcat","source":"GHSA-86fp-jgwm-wgj5"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2002-1566"},"products":["n/a"],"published":"2003-09-19","related":[{"cvss_score":10,"headline":"Apache Tomcat Path Equivalence","id":"CVE-2025-24813","kev_date_added":"2025-04-01","published":"2025-03-10"},{"cvss_score":9.8,"headline":"Apache Tomcat Remote Code Execution","id":"CVE-2016-8735","kev_date_added":"2023-05-12","published":"2017-04-06"},{"cvss_score":8.1,"headline":"Apache Tomcat Remote Code Execution","id":"CVE-2017-12617","kev_date_added":"2022-03-25","published":"2017-10-03"},{"cvss_score":8.1,"headline":"Apache Tomcat on Windows Remote Code Execution","id":"CVE-2017-12615","kev_date_added":"2022-03-25","published":"2017-09-19"},{"cvss_score":7.5,"headline":"Apache Tomcat Missing Encryption of Sensitive Data","id":"CVE-2026-34486","kev_date_added":"2026-08-04","published":"2026-04-09"},{"cvss_score":9.8,"headline":"Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete","id":"CVE-2026-65637","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":9.8,"headline":"Apache Tomcat: Limited replay attack possible with DIGEST authentication","id":"CVE-2026-65905","kev_date_added":null,"published":"2026-08-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-08","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary scripts and steal cookies via crafted URLs in Apache Tomcat, requiring user interaction.","url":"https://insights.sbomify.com/CVE-2002-1567/"}