# CVE-2002-1567: Apache Tomcat XSS Vulnerability

> Remote attackers can execute arbitrary scripts and steal cookies via crafted URLs in Apache Tomcat, requiring user interaction.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Sep 2003
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-86fp-jgwm-wgj5

## What is CVE-2002-1567?

CVE-2002-1567 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 19 Sep 2003. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Apache Tomcat 4.1 allows remote attackers to execute arbitrary web script and steal cookies via a URL with encoded newlines followed by a request to a .jsp file whose name contains the script.

## Which versions are affected by CVE-2002-1567?

2 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 | 4.1.29 |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 | 4.1.29 |

Products: Apache Tomcat.

## How do I fix CVE-2002-1567?

Upgrade org.apache.tomcat:tomcat to 4.1.29 or later.

## Is CVE-2002-1567 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2002-1567 exists.

Public exploit code:

- Apache Tomcat 4.1 - JSP Request Cross-Site Scripting (exploitdb)

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2002-1567 and fix it if it is affected.

What it is: CVE-2002-1567 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 19 Sep 2003. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2002-1567 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.29
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2002-1567/ (Markdown: https://insights.sbomify.com/CVE-2002-1567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2002-1567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2002-1567
- OSV: https://osv.dev/vulnerability/CVE-2002-1567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2002-1567/
Summaries are generated and may contain mistakes; the official description above is the record.
