CVE-2002-2006 Apache Tomcat Default Installation Reveals Sensitive Information
Remote attackers can obtain sensitive system information via default example servlets in Apache Tomcat.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2002-2006?
CVE-2002-2006 is a medium-severity vulnerability in Apache Tomcat, published on 14 Jul 2005. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The default installation of Apache Tomcat 4.0 through 4.1 and 3.0 through 3.3.1 allows remote attackers to obtain the installation path and other sensitive system information via the (1) SnoopServlet or (2) TroubleShooter example servlets.
Which versions are affected by CVE-2002-2006?
4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 3.0 | 3.3a |
org.apache.tomcat:tomcat Maven | From 3.0 | 3.3a |
org.apache.tomcat:tomcat Maven | From 4.0.0 | 4.1.0 |
org.apache.tomcat:tomcat Maven | From 4.0.0 | 4.1.0 |
Products include Apache Tomcat.
How do I fix CVE-2002-2006?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 3.3a or 4.1.0.
Is CVE-2002-2006 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2002-2006 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-8g4f-fh7f-4fwh.