# CVE-2002-2006: Apache Tomcat Default Installation Reveals Sensitive Information

> Remote attackers can obtain sensitive system information via default example servlets in Apache Tomcat.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2005
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-8g4f-fh7f-4fwh

## What is CVE-2002-2006?

CVE-2002-2006 is a medium-severity vulnerability in Apache Tomcat, published on 14 Jul 2005. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The default installation of Apache Tomcat 4.0 through 4.1 and 3.0 through 3.3.1 allows remote attackers to obtain the installation path and other sensitive system information via the (1) SnoopServlet or (2) TroubleShooter example servlets.

## Which versions are affected by CVE-2002-2006?

4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 3.0 | 3.3a |
| `org.apache.tomcat:tomcat` | Maven | From 3.0 | 3.3a |
| `org.apache.tomcat:tomcat` | Maven | From 4.0.0 | 4.1.0 |
| `org.apache.tomcat:tomcat` | Maven | From 4.0.0 | 4.1.0 |

Products: Apache Tomcat.

## How do I fix CVE-2002-2006?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 3.3a or 4.1.0.

## Is CVE-2002-2006 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2002-2006 exists.

Public exploit code:

- Apache Tomcat 4.0/4.1 - Servlet Full Path Disclosure (exploitdb)

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2002-2006 and fix it if it is affected.

What it is: CVE-2002-2006 is a medium-severity vulnerability in Apache Tomcat, published on 14 Jul 2005. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2002-2006 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 3.0; fixed in 3.3a
- org.apache.tomcat:tomcat (Maven): affected from 3.0; fixed in 3.3a
- org.apache.tomcat:tomcat (Maven): affected from 4.0.0; fixed in 4.1.0
- org.apache.tomcat:tomcat (Maven): affected from 4.0.0; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2002-2006/ (Markdown: https://insights.sbomify.com/CVE-2002-2006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2002-2006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2002-2006
- OSV: https://osv.dev/vulnerability/CVE-2002-2006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2002-2006/
Summaries are generated and may contain mistakes; the official description above is the record.
