# CVE-2003-0026: Memory corruption in n/a

> Remote attackers can execute arbitrary code on ISC DHCP servers via a stack-based buffer overflow in the minires library triggered by a long hostname in a DHCP message.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2003
- **Updated:** 8 Aug 2024
- **Also known as:** DSA-231, GHSA-jgfq-29vq-wj6m

## What is CVE-2003-0026?

CVE-2003-0026 is a high-severity memory corruption vulnerability in n/a, published on 16 Jan 2003. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple stack-based buffer overflows in the error handling routines of the minires library, as used in the NSUPDATE capability for ISC DHCPD 3.0 through 3.0.1RC10, allow remote attackers to execute arbitrary code via a DHCP message containing a long hostname.

## Which versions are affected by CVE-2003-0026?

It affects 1 product.


Products: Isc Dhcpd.

## How do I fix CVE-2003-0026?

Upgrade to a fixed version.

## Is CVE-2003-0026 being exploited?

There is no known exploitation of CVE-2003-0026 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2004-1006](https://insights.sbomify.com/CVE-2004-1006/): Code injection in n/a (critical 10.0)
- [CVE-2002-0702](https://insights.sbomify.com/CVE-2002-0702/): Code injection in n/a (critical 10.0)
- [CVE-2019-6470](https://insights.sbomify.com/CVE-2019-6470/): dhcpd: use-after-free error leads crash in IPv6 mode when using mismatched BIND libraries (medium 6.5)
- [CVE-2006-3122](https://insights.sbomify.com/CVE-2006-3122/): Denial of service in n/a (medium 5.0)
- [CVE-2003-0039](https://insights.sbomify.com/CVE-2003-0039/): Denial of service in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2003-0026 and fix it if it is affected.

What it is: CVE-2003-0026 is a high-severity memory corruption vulnerability in n/a, published on 16 Jan 2003. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2003-0026 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2003-0026/ (Markdown: https://insights.sbomify.com/CVE-2003-0026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2003-0026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2003-0026
- OSV: https://osv.dev/vulnerability/CVE-2003-0026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2003-0026/
Summaries are generated and may contain mistakes; the official description above is the record.
