{"answers":{"affected":"3 open source packages ship an affected version, including mailman. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2003-0038 exists.","fix":"Upgrade mailman to 2.1.1 or later.","what":"CVE-2003-0038 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Jan 2003. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2003-0038 and fix it if it is affected.\n\nWhat it is: CVE-2003-0038 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Jan 2003. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2003-0038 exists.\n\nAffected packages and fixed versions:\n- mailman (PyPI): affected all versions; fixed in 2.1.1\n- mailman (PyPI): affected all versions; fixed in 2.1.1\n- mailman (PyPI): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2003-0038/ (Markdown: https://insights.sbomify.com/CVE-2003-0038/index.md)","id":"CVE-2003-0038","markdown":"https://insights.sbomify.com/CVE-2003-0038/index.md","name":"CVE-2003-0038","record":{"aliases":["GHSA-82rm-28q9-435p","PYSEC-2026-657"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Mailman mailing list","requires_auth":"none","summary":"Remote attackers can inject malicious scripts into Mailman web pages via email or language parameters, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mailman","vendor":"gnu"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.","ecosystems":["PyPI"],"exploits":{"exploitdb":2,"first_seen":"2003-01-24","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2003-01-24","kind":"exploitdb","ref":"22198","stars":null,"title":"GNU Mailman 2.1 - 'email' Cross-Site Scripting"},{"date":"2003-01-24","kind":"exploitdb","ref":"22199","stars":null,"title":"GNU Mailman 2.1 - Error Page Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Mailman Cross-site scripting (XSS) vulnerability","id":"CVE-2003-0038","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2003"},"n_packages":3,"n_references":7,"next":{"headline":"Denial of service in n/a","id":"CVE-2003-0039"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":null,"source":"GHSA-82rm-28q9-435p"},{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":"pkg:pypi/mailman","source":"GHSA-82rm-28q9-435p"},{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"mailman","purl":"pkg:pypi/mailman","source":"PYSEC-2026-657"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2003-0037"},"products":["n/a"],"published":"2003-01-29","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-6893","kev_date_added":null,"published":"2016-09-02"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-7123","kev_date_added":null,"published":"2016-09-02"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2005-4153","kev_date_added":null,"published":"2005-12-11"},{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2006-2191","kev_date_added":null,"published":"2006-09-19"},{"cvss_score":7.5,"headline":"Weak cryptography in n/a","id":"CVE-2004-1143","kev_date_added":null,"published":"2005-01-19"},{"cvss_score":7.5,"headline":"Cross-site scripting in n/a","id":"CVE-2002-0855","kev_date_added":null,"published":"2002-08-14"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2001-1132","kev_date_added":null,"published":"2002-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-08","vendors":["n/a"]},"summary":"Remote attackers can inject malicious scripts into Mailman web pages via email or language parameters, requiring user interaction to execute.","url":"https://insights.sbomify.com/CVE-2003-0038/"}