# CVE-2003-0038: Mailman Cross-site scripting (XSS) vulnerability

> Remote attackers can inject malicious scripts into Mailman web pages via email or language parameters, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jan 2003
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-82rm-28q9-435p, PYSEC-2026-657

## What is CVE-2003-0038?

CVE-2003-0038 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Jan 2003. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in options.py for Mailman 2.1 allows remote attackers to inject script or HTML into web pages via the (1) email or (2) language parameters.

## Which versions are affected by CVE-2003-0038?

3 open source packages ship an affected version, including mailman. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mailman` | PyPI | All versions | 2.1.1 |
| `mailman` | PyPI | All versions | 2.1.1 |
| `mailman` | PyPI | All versions | 2.1.1 |

Products: Gnu Mailman.

## How do I fix CVE-2003-0038?

Upgrade mailman to 2.1.1 or later.

## Is CVE-2003-0038 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2003-0038 exists.

Public exploit code:

- GNU Mailman 2.1 - 'email' Cross-Site Scripting (exploitdb)
- GNU Mailman 2.1 - Error Page Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2016-6893](https://insights.sbomify.com/CVE-2016-6893/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2016-7123](https://insights.sbomify.com/CVE-2016-7123/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2005-4153](https://insights.sbomify.com/CVE-2005-4153/): Denial of service in n/a (high 7.8)
- [CVE-2006-2191](https://insights.sbomify.com/CVE-2006-2191/): Other in n/a (high 7.5)
- [CVE-2004-1143](https://insights.sbomify.com/CVE-2004-1143/): Weak cryptography in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2003-0038 and fix it if it is affected.

What it is: CVE-2003-0038 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Jan 2003. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2003-0038 exists.

Affected packages and fixed versions:
- mailman (PyPI): affected all versions; fixed in 2.1.1
- mailman (PyPI): affected all versions; fixed in 2.1.1
- mailman (PyPI): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2003-0038/ (Markdown: https://insights.sbomify.com/CVE-2003-0038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2003-0038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2003-0038
- OSV: https://osv.dev/vulnerability/CVE-2003-0038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2003-0038/
Summaries are generated and may contain mistakes; the official description above is the record.
