# CVE-2004-0412: Mailman Sensitive Information Disclosure

> Remote attackers can obtain user passwords by sending a crafted email request to the Mailman server, exposing sensitive credentials.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2004
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-hj4h-vqpq-95wg, PYSEC-2026-658

## What is CVE-2004-0412?

CVE-2004-0412 is a medium-severity vulnerability in n/a, published on 3 Jun 2004. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mailman before 2.1.5 allows remote attackers to obtain user passwords via a crafted email request to the Mailman server.

## Which versions are affected by CVE-2004-0412?

3 open source packages ship an affected version, including mailman. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mailman` | PyPI | All versions | 2.1.5 |
| `mailman` | PyPI | All versions | 2.1.5 |
| `mailman` | PyPI | All versions | 2.1.5 |

Products: Gnu Mailman.

## How do I fix CVE-2004-0412?

Upgrade mailman to 2.1.5 or later.

## Is CVE-2004-0412 being exploited?

There is no known exploitation of CVE-2004-0412 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-6893](https://insights.sbomify.com/CVE-2016-6893/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2016-7123](https://insights.sbomify.com/CVE-2016-7123/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2005-4153](https://insights.sbomify.com/CVE-2005-4153/): Denial of service in n/a (high 7.8)
- [CVE-2006-2191](https://insights.sbomify.com/CVE-2006-2191/): Other in n/a (high 7.5)
- [CVE-2004-1143](https://insights.sbomify.com/CVE-2004-1143/): Weak cryptography in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2004-0412 and fix it if it is affected.

What it is: CVE-2004-0412 is a medium-severity vulnerability in n/a, published on 3 Jun 2004. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2004-0412 in the wild and no public exploit code.

Affected packages and fixed versions:
- mailman (PyPI): affected all versions; fixed in 2.1.5
- mailman (PyPI): affected all versions; fixed in 2.1.5
- mailman (PyPI): affected all versions; fixed in 2.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2004-0412/ (Markdown: https://insights.sbomify.com/CVE-2004-0412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2004-0412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2004-0412
- OSV: https://osv.dev/vulnerability/CVE-2004-0412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2004-0412/
Summaries are generated and may contain mistakes; the official description above is the record.
