# CVE-2004-0708: MoinMoin allows administrative access

> Remote attackers can escalate privileges by creating a user with the same name as an existing high-privilege group in MoinMoin Wiki.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2004
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-7jrp-r6jx-32cw, PYSEC-2026-671

## What is CVE-2004-0708?

CVE-2004-0708 is a high-severity vulnerability in n/a, published on 21 Jul 2004. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MoinMoin 1.2.1 and earlier allows remote attackers to gain privileges by creating a user with the same name as an existing group that has higher privileges.

## Which versions are affected by CVE-2004-0708?

3 open source packages ship an affected version, including moin and Moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.2.2 |
| `moin` | PyPI | All versions | 1.2.2 |
| `Moin` | PyPI | All versions | 1.2.2 |

Products: Moinmoin Moinmoin.

## How do I fix CVE-2004-0708?

Upgrade moin to 1.2.2 or later.

## Is CVE-2004-0708 being exploited?

There is no known exploitation of CVE-2004-0708 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2004-1463](https://insights.sbomify.com/CVE-2004-1463/): MoinMoin Improper Privilege Management (critical 10.0)
- [CVE-2004-1462](https://insights.sbomify.com/CVE-2004-1462/): MoinMoin Improper Access Control (high 7.5)
- [CVE-2008-1937](https://insights.sbomify.com/CVE-2008-1937/): MoinMoin vulnerable to privilege escalation (medium 6.8)
- [CVE-2007-2423](https://insights.sbomify.com/CVE-2007-2423/): Cross-site scripting in n/a (medium 5.8)
- [CVE-2008-1099](https://insights.sbomify.com/CVE-2008-1099/): MoinMoin Improper Access Control (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2004-0708 and fix it if it is affected.

What it is: CVE-2004-0708 is a high-severity vulnerability in n/a, published on 21 Jul 2004. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2004-0708 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.2.2
- moin (PyPI): affected all versions; fixed in 1.2.2
- Moin (PyPI): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2004-0708/ (Markdown: https://insights.sbomify.com/CVE-2004-0708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2004-0708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2004-0708
- OSV: https://osv.dev/vulnerability/CVE-2004-0708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2004-0708/
Summaries are generated and may contain mistakes; the official description above is the record.
