# CVE-2004-1177: mailman Cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML via a URL in Mailman's driver script, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2005
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-rh6c-jh4c-9fg3, PYSEC-2026-659, RHSA-2005:235

## What is CVE-2004-1177?

CVE-2004-1177 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jan 2005. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the driver script in mailman before 2.1.5 allows remote attackers to inject arbitrary web script or HTML via a URL, which is not properly escaped in the resulting error page.

## Which versions are affected by CVE-2004-1177?

3 open source packages ship an affected version, including mailman. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mailman` | PyPI | All versions | 2.1.5 |
| `mailman` | PyPI | All versions | 2.1.5 |
| `mailman` | PyPI | All versions | 2.1.5 |
| `mailman` | Red Hat:enterprise_linux:3::as | All versions | 3:2.1.5-25.rhel3 |
| `mailman-debuginfo` | Red Hat:enterprise_linux:3::as | All versions | 3:2.1.5-25.rhel3 |
| `mailman` | Red Hat:enterprise_linux:3::desktop | All versions | 3:2.1.5-25.rhel3 |
| `mailman-debuginfo` | Red Hat:enterprise_linux:3::desktop | All versions | 3:2.1.5-25.rhel3 |
| `mailman` | Red Hat:enterprise_linux:3::es | All versions | 3:2.1.5-25.rhel3 |
| `mailman-debuginfo` | Red Hat:enterprise_linux:3::es | All versions | 3:2.1.5-25.rhel3 |
| `mailman` | Red Hat:enterprise_linux:3::ws | All versions | 3:2.1.5-25.rhel3 |
| `mailman-debuginfo` | Red Hat:enterprise_linux:3::ws | All versions | 3:2.1.5-25.rhel3 |
| `mailman` | Red Hat:enterprise_linux:4::as | All versions | 3:2.1.5-33.rhel4 |
| `mailman-debuginfo` | Red Hat:enterprise_linux:4::as | All versions | 3:2.1.5-33.rhel4 |
| `mailman` | Red Hat:enterprise_linux:4::desktop | All versions | 3:2.1.5-33.rhel4 |
| `mailman-debuginfo` | Red Hat:enterprise_linux:4::desktop | All versions | 3:2.1.5-33.rhel4 |
| `mailman` | Red Hat:enterprise_linux:4::es | All versions | 3:2.1.5-33.rhel4 |
| `mailman-debuginfo` | Red Hat:enterprise_linux:4::es | All versions | 3:2.1.5-33.rhel4 |
| `mailman` | Red Hat:enterprise_linux:4::ws | All versions | 3:2.1.5-33.rhel4 |
| `mailman-debuginfo` | Red Hat:enterprise_linux:4::ws | All versions | 3:2.1.5-33.rhel4 |

Products: Gnu Mailman.

## How do I fix CVE-2004-1177?

Upgrade mailman to 2.1.5 or later.

## Is CVE-2004-1177 being exploited?

There is no known exploitation of CVE-2004-1177 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-6893](https://insights.sbomify.com/CVE-2016-6893/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2016-7123](https://insights.sbomify.com/CVE-2016-7123/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2005-4153](https://insights.sbomify.com/CVE-2005-4153/): Denial of service in n/a (high 7.8)
- [CVE-2006-2191](https://insights.sbomify.com/CVE-2006-2191/): Other in n/a (high 7.5)
- [CVE-2004-1143](https://insights.sbomify.com/CVE-2004-1143/): Weak cryptography in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2004-1177 and fix it if it is affected.

What it is: CVE-2004-1177 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jan 2005. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2004-1177 in the wild and no public exploit code.

Affected packages and fixed versions:
- mailman (PyPI): affected all versions; fixed in 2.1.5
- mailman (PyPI): affected all versions; fixed in 2.1.5
- mailman (PyPI): affected all versions; fixed in 2.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2004-1177/ (Markdown: https://insights.sbomify.com/CVE-2004-1177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2004-1177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2004-1177
- OSV: https://osv.dev/vulnerability/CVE-2004-1177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2004-1177/
Summaries are generated and may contain mistakes; the official description above is the record.
