# CVE-2004-1463: MoinMoin Improper Privilege Management

> An unknown vulnerability in MoinMoin's PageEditor related to Access Control Lists may allow unauthorized access or bypass of security controls.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 13 Feb 2005
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-9xh4-wpx8-rg2w, PYSEC-2026-674

## What is CVE-2004-1463?

CVE-2004-1463 is a critical missing authorization vulnerability in n/a, published on 13 Feb 2005. It can be exploited over the network.

### Official description

Unknown vulnerability in the PageEditor in MoinMoin 1.2.2 and earlier, related to Access Control Lists (ACL), has unknown impact.

## Which versions are affected by CVE-2004-1463?

3 open source packages ship an affected version, including moin and Moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.2.3 |
| `moin` | PyPI | All versions | 1.2.3 |
| `Moin` | PyPI | All versions | 1.2.3 |

Products: Moinmoin Moinmoin.

## How do I fix CVE-2004-1463?

Upgrade moin to 1.2.3 or later.

## Is CVE-2004-1463 being exploited?

There is no known exploitation of CVE-2004-1463 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2004-1462](https://insights.sbomify.com/CVE-2004-1462/): MoinMoin Improper Access Control (high 7.5)
- [CVE-2004-0708](https://insights.sbomify.com/CVE-2004-0708/): MoinMoin allows administrative access (high 7.5)
- [CVE-2008-1937](https://insights.sbomify.com/CVE-2008-1937/): MoinMoin vulnerable to privilege escalation (medium 6.8)
- [CVE-2007-2423](https://insights.sbomify.com/CVE-2007-2423/): Cross-site scripting in n/a (medium 5.8)
- [CVE-2008-1099](https://insights.sbomify.com/CVE-2008-1099/): MoinMoin Improper Access Control (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2004-1463 and fix it if it is affected.

What it is: CVE-2004-1463 is a critical missing authorization vulnerability in n/a, published on 13 Feb 2005. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2004-1463 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.2.3
- moin (PyPI): affected all versions; fixed in 1.2.3
- Moin (PyPI): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2004-1463/ (Markdown: https://insights.sbomify.com/CVE-2004-1463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2004-1463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2004-1463
- OSV: https://osv.dev/vulnerability/CVE-2004-1463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2004-1463/
Summaries are generated and may contain mistakes; the official description above is the record.
