{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2004-2278 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2004-2278 yet. Limit exposure of the affected software until one is available.","what":"CVE-2004-2278 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jul 2005. It can be exploited over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2004-2278 and fix it if it is affected.\n\nWhat it is: CVE-2004-2278 is a medium-severity cross-site scripting vulnerability in n/a, published on 19 Jul 2005. It can be exploited over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2004-2278 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2004-2278/ (Markdown: https://insights.sbomify.com/CVE-2004-2278/index.md)","id":"CVE-2004-2278","markdown":"https://insights.sbomify.com/CVE-2004-2278/index.md","name":"CVE-2004-2278","record":{"aliases":["GHSA-7jr2-5wcw-ghq8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"vHost web GUI","requires_auth":"unknown","summary":"An unknown cross-site scripting vulnerability in the vHost web GUI allows attackers to inject scripts, requiring an upgrade to version 3.10r1.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"vhost","vendor":"chaogic_systems"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Unknown cross-site scripting (XSS) vulnerability in the web GUI in vHost before 3.10r1 has unknown impact and attack vectors.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2278","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2004"},"n_packages":0,"n_references":6,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2004-2279"},"packages":[],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2004-2277"},"products":["n/a"],"published":"2005-07-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-08","vendors":["n/a"]},"summary":"An unknown cross-site scripting vulnerability in the vHost web GUI allows attackers to inject scripts, requiring an upgrade to version 3.10r1.","url":"https://insights.sbomify.com/CVE-2004-2278/"}