# CVE-2004-2381: Jetty HTTP Server Denial of Service vulnerability

> Remote attackers can cause denial of service in Jetty HTTP Server by sending requests with large Content-Length headers, leading to memory exhaustion and crashes.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2005
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-p5rr-q5g6-gm42

## What is CVE-2004-2381?

CVE-2004-2381 is a medium-severity denial of service vulnerability in n/a, published on 16 Aug 2005. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HttpRequest.java in Jetty HTTP Server before 4.2.19 allows remote attackers to cause denial of service (memory usage and application crash) via HTTP requests with a large Content-Length.

## Which versions are affected by CVE-2004-2381?

2 open source packages ship an affected version, including org.mortbay.jetty:jetty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.mortbay.jetty:jetty` | Maven | All versions | 4.2.19 |
| `org.mortbay.jetty:jetty` | Maven | All versions | 4.2.19 |

Products: Jetty Jetty Http Server.

## How do I fix CVE-2004-2381?

Upgrade org.mortbay.jetty:jetty to 4.2.19 or later.

## Is CVE-2004-2381 being exploited?

There is no known exploitation of CVE-2004-2381 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2006-6969](https://insights.sbomify.com/CVE-2006-6969/): Jetty Uses Predictable Session Identifiers (medium 6.8)
- [CVE-2002-1178](https://insights.sbomify.com/CVE-2002-1178/): Path traversal in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2004-2381 and fix it if it is affected.

What it is: CVE-2004-2381 is a medium-severity denial of service vulnerability in n/a, published on 16 Aug 2005. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2004-2381 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.mortbay.jetty:jetty (Maven): affected all versions; fixed in 4.2.19
- org.mortbay.jetty:jetty (Maven): affected all versions; fixed in 4.2.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2004-2381/ (Markdown: https://insights.sbomify.com/CVE-2004-2381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2004-2381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2004-2381
- OSV: https://osv.dev/vulnerability/CVE-2004-2381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2004-2381/
Summaries are generated and may contain mistakes; the official description above is the record.
