CVE-2005-10002 almosteffortless secure-files Plugin secure-files.php sf_downloads path traversal

Medium 5.5 Published Updated

An attacker can exploit a path traversal vulnerability in the secure-files plugin to read arbitrary files from the server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2005-10002?

CVE-2005-10002 is a medium-severity path traversal vulnerability in almosteffortless secure-files Plugin, published on 29 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability, which was classified as critical, was found in almosteffortless secure-files Plugin up to 1.1 on WordPress. Affected is the function sf_downloads of the file secure-files.php. The manipulation of the argument downloadfile leads to path traversal. Upgrading to version 1.2 is able to address this issue. The name of the patch is cab025e5fc2bcdad8032d833ebc38e6bd2a13c92. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-243804.

Weakness: CWE-22

Which versions are affected by CVE-2005-10002?

It affects 1 product.

Products include Wp-Plugins Secure Files.

How do I fix CVE-2005-10002?

No fix has been published for CVE-2005-10002 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2005-10002 being exploited?

There is no known exploitation of CVE-2005-10002 in the wild and no public exploit code.

Sources

Also known as GHSA-8v2m-x872-56fc.

Is CVE-2005-10002 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free