{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2005-10002 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2005-10002 yet. Limit exposure of the affected software until one is available.","what":"CVE-2005-10002 is a medium-severity path traversal vulnerability in almosteffortless secure-files Plugin, published on 29 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2005-10002 and fix it if it is affected.\n\nWhat it is: CVE-2005-10002 is a medium-severity path traversal vulnerability in almosteffortless secure-files Plugin, published on 29 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2005-10002 in the wild and no public exploit code.\n\nAffected product: almosteffortless secure-files Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2005-10002/ (Markdown: https://insights.sbomify.com/CVE-2005-10002/index.md)","id":"CVE-2005-10002","markdown":"https://insights.sbomify.com/CVE-2005-10002/index.md","name":"CVE-2005-10002","record":{"aliases":["GHSA-8v2m-x872-56fc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"An attacker can exploit a path traversal vulnerability in the secure-files plugin to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"secure_files","vendor":"wp-plugins"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability, which was classified as critical, was found in almosteffortless secure-files Plugin up to 1.1 on WordPress. Affected is the function sf_downloads of the file secure-files.php. The manipulation of the argument downloadfile leads to path traversal. Upgrading to version 1.2 is able to address this issue. The name of the patch is cab025e5fc2bcdad8032d833ebc38e6bd2a13c92. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-243804.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"almosteffortless secure-files Plugin secure-files.php sf_downloads path traversal","id":"CVE-2005-10002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2005"},"n_packages":0,"n_references":3,"next":{"headline":"mikexstudios Xcomic os command injection","id":"CVE-2005-10003"},"packages":[],"prev":{"headline":"Netegrity SiteMinder Login smpwservicescgi.exe redirect","id":"CVE-2005-10001"},"products":["secure-files Plugin"],"published":"2023-10-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-08","vendors":["almosteffortless"]},"summary":"An attacker can exploit a path traversal vulnerability in the secure-files plugin to read arbitrary files from the server.","url":"https://insights.sbomify.com/CVE-2005-10002/"}