# CVE-2005-10002: almosteffortless secure-files Plugin secure-files.php sf_downloads path traversal

> An attacker can exploit a path traversal vulnerability in the secure-files plugin to read arbitrary files from the server.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Oct 2023
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-8v2m-x872-56fc

## What is CVE-2005-10002?

CVE-2005-10002 is a medium-severity path traversal vulnerability in almosteffortless secure-files Plugin, published on 29 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, was found in almosteffortless secure-files Plugin up to 1.1 on WordPress. Affected is the function sf_downloads of the file secure-files.php. The manipulation of the argument downloadfile leads to path traversal. Upgrading to version 1.2 is able to address this issue. The name of the patch is cab025e5fc2bcdad8032d833ebc38e6bd2a13c92. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-243804.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2005-10002?

It affects 1 product.


Products: Wp-Plugins Secure Files.

## How do I fix CVE-2005-10002?

No fix has been published for CVE-2005-10002 yet. Limit exposure of the affected software until one is available.

## Is CVE-2005-10002 being exploited?

There is no known exploitation of CVE-2005-10002 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2005-10002 and fix it if it is affected.

What it is: CVE-2005-10002 is a medium-severity path traversal vulnerability in almosteffortless secure-files Plugin, published on 29 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2005-10002 in the wild and no public exploit code.

Affected product: almosteffortless secure-files Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2005-10002/ (Markdown: https://insights.sbomify.com/CVE-2005-10002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2005-10002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2005-10002
- OSV: https://osv.dev/vulnerability/CVE-2005-10002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2005-10002/
Summaries are generated and may contain mistakes; the official description above is the record.
