{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2005-3621 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to 2.6.4-pl4 or later.","what":"CVE-2005-3621 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 16 Nov 2005. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2005-3621 and fix it if it is affected.\n\nWhat it is: CVE-2005-3621 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 16 Nov 2005. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2005-3621 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 2.6.4-pl4\n- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 2.6.4-pl4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2005-3621/ (Markdown: https://insights.sbomify.com/CVE-2005-3621/index.md)","id":"CVE-2005-3621","markdown":"https://insights.sbomify.com/CVE-2005-3621/index.md","name":"CVE-2005-3621","record":{"aliases":["DEBIAN-CVE-2005-3621","GHSA-wj42-52pv-wfj2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Database administration tool","requires_auth":"none","summary":"Remote attackers can perform HTTP response splitting via CRLF injection in phpMyAdmin, potentially bypassing security controls.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"CRLF injection vulnerability in phpMyAdmin before 2.6.4-pl4 allows remote attackers to conduct HTTP response splitting attacks via unspecified scripts.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin CRLF Injection Vulnerability","id":"CVE-2005-3621","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"other","year":"2005"},"n_packages":2,"n_references":6,"next":{"headline":"Information disclosure in n/a","id":"CVE-2005-3622"},"packages":[{"ecosystem":"Packagist","fixed":["2.6.4-pl4"],"introduced":["0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-wj42-52pv-wfj2"},{"ecosystem":"Packagist","fixed":["2.6.4-pl4"],"introduced":["0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-wj42-52pv-wfj2"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2005-3620"},"products":["n/a"],"published":"2005-11-16","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can perform HTTP response splitting via CRLF injection in phpMyAdmin, potentially bypassing security controls.","url":"https://insights.sbomify.com/CVE-2005-3621/"}