# CVE-2005-3621: phpMyAdmin CRLF Injection Vulnerability

> Remote attackers can perform HTTP response splitting via CRLF injection in phpMyAdmin, potentially bypassing security controls.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2005
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2005-3621, GHSA-wj42-52pv-wfj2

## What is CVE-2005-3621?

CVE-2005-3621 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 16 Nov 2005. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CRLF injection vulnerability in phpMyAdmin before 2.6.4-pl4 allows remote attackers to conduct HTTP response splitting attacks via unspecified scripts.

## Which versions are affected by CVE-2005-3621?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 2.6.4-pl4 |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 2.6.4-pl4 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2005-3621?

Upgrade phpmyadmin/phpmyadmin to 2.6.4-pl4 or later.

## Is CVE-2005-3621 being exploited?

There is no known exploitation of CVE-2005-3621 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2005-3621 and fix it if it is affected.

What it is: CVE-2005-3621 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 16 Nov 2005. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2005-3621 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 2.6.4-pl4
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 2.6.4-pl4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2005-3621/ (Markdown: https://insights.sbomify.com/CVE-2005-3621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2005-3621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2005-3621
- OSV: https://osv.dev/vulnerability/CVE-2005-3621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2005-3621/
Summaries are generated and may contain mistakes; the official description above is the record.
