{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-0047 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2006-0047 is a medium-severity denial of service vulnerability in n/a, published on 7 Mar 2006. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2006-0047 and fix it if it is affected.\n\nWhat it is: CVE-2006-0047 is a medium-severity denial of service vulnerability in n/a, published on 7 Mar 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-0047 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-0047/ (Markdown: https://insights.sbomify.com/CVE-2006-0047/index.md)","id":"CVE-2006-0047","markdown":"https://insights.sbomify.com/CVE-2006-0047/index.md","name":"CVE-2006-0047","record":{"aliases":["DEBIAN-CVE-2006-0047","DSA-994-1","GHSA-c6gj-v86g-r7jw","openSUSE-SU-2024:10765-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Freeciv game server","requires_auth":"none","summary":"Remote attackers can crash the Freeciv server by sending crafted packets with negative compressed size values, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"freeciv","vendor":"freeciv"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"packets.c in Freeciv 2.0 before 2.0.8 allows remote attackers to cause a denial of service (server crash) via crafted packets with negative compressed size values.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":1,"first_seen":"2006-03-06","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2006-03-06","kind":"exploitdb","ref":"1557","stars":null,"title":"Freeciv 2.0.7 - Jumbo Malloc Crash (Denial of Service)"}],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2006-0047","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2006"},"n_packages":1,"n_references":11,"next":{"headline":"Denial of service in n/a","id":"CVE-2006-0048"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.6.5-1.2"],"introduced":["0"],"last_affected":[],"package":"freeciv","purl":"pkg:rpm/opensuse/freeciv\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10765-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2006-0046"},"products":["n/a"],"published":"2006-03-07","related":[{"cvss_score":10,"headline":"Code injection in n/a","id":"CVE-2010-2445","kev_date_added":null,"published":"2010-07-07"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2022-39047","kev_date_added":null,"published":"2022-08-31"},{"cvss_score":7.5,"headline":"Denial of service in freeciv","id":"CVE-2012-6083","kev_date_added":null,"published":"2020-01-23"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2006-3913","kev_date_added":null,"published":"2006-07-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can crash the Freeciv server by sending crafted packets with negative compressed size values, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2006-0047/"}