CVE-2006-0254 Apache Geronimo console 1.0 vulnerable to cross-site scripting

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML into Apache Geronimo via specific parameters, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2006-0254?

CVE-2006-0254 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Jan 2006. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in Apache Geronimo 1.0 allow remote attackers to inject arbitrary web script or HTML via the (1) time parameter to cal2.jsp and (2) any invalid parameter, which causes an XSS when the log file is viewed by the Web-Access-Log viewer.

Which versions are affected by CVE-2006-0254?

2 open source packages ship an affected version, including geronimo:geronimo-console-standard. It affects 1 product.

PackageAffectedFixed in
geronimo:geronimo-console-standard MavenAll versions1.1
geronimo:geronimo-console-standard MavenAll versions1.1

Products include Apache Geronimo.

How do I fix CVE-2006-0254?

Upgrade geronimo:geronimo-console-standard to 1.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2006-0254 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-0254 exists.

Public exploit code: 2 Exploit-DB entries.

Sources

Also known as GHSA-2jxh-3cx8-xw65.

Is CVE-2006-0254 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free