# CVE-2006-0847: CherryPy Directory traversal vulnerability

> Remote attackers can read arbitrary files via directory traversal in the CherryPy staticfilter component.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Feb 2006
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-vx77-5pf4-c9wr, PYSEC-2006-1

## What is CVE-2006-0847?

CVE-2006-0847 is a medium-severity path traversal vulnerability in n/a, published on 22 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in the staticfilter component in CherryPy before 2.1.1 allows remote attackers to read arbitrary files via ".." sequences in unspecified vectors.

## Which versions are affected by CVE-2006-0847?

3 open source packages ship an affected version, including cherrypy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cherrypy` | PyPI | All versions | 2.1.1 |
| `cherrypy` | PyPI | All versions | 2.1.1 |
| `cherrypy` | PyPI | All versions | 2.1.1 |

Products: Cherrypy Cherrypy.

## How do I fix CVE-2006-0847?

Upgrade cherrypy to 2.1.1 or later.

## Is CVE-2006-0847 being exploited?

There is no known exploitation of CVE-2006-0847 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-0252](https://insights.sbomify.com/CVE-2008-0252/): CherryPy Malicious cookies allow access to files outside the session directory (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-0847 and fix it if it is affected.

What it is: CVE-2006-0847 is a medium-severity path traversal vulnerability in n/a, published on 22 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2006-0847 in the wild and no public exploit code.

Affected packages and fixed versions:
- cherrypy (PyPI): affected all versions; fixed in 2.1.1
- cherrypy (PyPI): affected all versions; fixed in 2.1.1
- cherrypy (PyPI): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-0847/ (Markdown: https://insights.sbomify.com/CVE-2006-0847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-0847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-0847
- OSV: https://osv.dev/vulnerability/CVE-2006-0847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-0847/
Summaries are generated and may contain mistakes; the official description above is the record.
