CVE-2006-0868 PEAR::Auth potential authentication bypass vulnerability
Remote attackers can falsify authentication credentials in PEAR::Auth library back ends, bypassing security controls and potentially taking over accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2006-0868?
CVE-2006-0868 is a high-severity authentication bypass vulnerability in n/a, published on 23 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Multiple unspecified injection vulnerabilities in unspecified Auth Container back ends for PEAR::Auth before 1.2.4, and 1.3.x before 1.3.0r4, allow remote attackers to "falsify authentication credentials," related to the "underlying storage containers."
Which versions are affected by CVE-2006-0868?
4 open source packages ship an affected version, including pear/auth. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pear/auth Packagist | All versions | 1.2.4 |
pear/auth Packagist | All versions | 1.2.4 |
pear/auth Packagist | From 1.3.0r1 | 1.3.0r4 |
pear/auth Packagist | From 1.3.0r1 | 1.3.0r4 |
Products include Pear Xml Rpc.
How do I fix CVE-2006-0868?
Upgrade pear/auth to a fixed version for your release line: 1.2.4 or 1.3.0r4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2006-0868 being exploited?
There is no known exploitation of CVE-2006-0868 in the wild and no public exploit code.
Sources
Also known as GHSA-76rh-xv36-9mrc.