{"answers":{"affected":"4 open source packages ship an affected version, including pear/auth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2006-0868 in the wild and no public exploit code.","fix":"Upgrade pear/auth to a fixed version for your release line: 1.2.4 or 1.3.0r4.","what":"CVE-2006-0868 is a high-severity authentication bypass vulnerability in n/a, published on 23 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2006-0868 and fix it if it is affected.\n\nWhat it is: CVE-2006-0868 is a high-severity authentication bypass vulnerability in n/a, published on 23 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2006-0868 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pear/auth (Packagist): affected all versions; fixed in 1.2.4\n- pear/auth (Packagist): affected all versions; fixed in 1.2.4\n- pear/auth (Packagist): affected from 1.3.0r1; fixed in 1.3.0r4\n- pear/auth (Packagist): affected from 1.3.0r1; fixed in 1.3.0r4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-0868/ (Markdown: https://insights.sbomify.com/CVE-2006-0868/index.md)","id":"CVE-2006-0868","markdown":"https://insights.sbomify.com/CVE-2006-0868/index.md","name":"CVE-2006-0868","record":{"aliases":["GHSA-76rh-xv36-9mrc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PEAR Auth library","requires_auth":"none","summary":"Remote attackers can falsify authentication credentials in PEAR::Auth library back ends, bypassing security controls and potentially taking over accounts.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"xml_rpc","vendor":"pear"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Multiple unspecified injection vulnerabilities in unspecified Auth Container back ends for PEAR::Auth before 1.2.4, and 1.3.x before 1.3.0r4, allow remote attackers to \"falsify authentication credentials,\" related to the \"underlying storage containers.\"","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PEAR::Auth potential authentication bypass vulnerability","id":"CVE-2006-0868","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2006"},"n_packages":4,"n_references":10,"next":{"headline":"Path traversal in n/a","id":"CVE-2006-0869"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"pear/auth","purl":null,"source":"GHSA-76rh-xv36-9mrc"},{"ecosystem":"Packagist","fixed":["1.2.4"],"introduced":["0"],"last_affected":[],"package":"pear/auth","purl":"pkg:composer/pear/auth","source":"GHSA-76rh-xv36-9mrc"},{"ecosystem":"Packagist","fixed":["1.3.0r4"],"introduced":["1.3.0r1"],"last_affected":[],"package":"pear/auth","purl":null,"source":"GHSA-76rh-xv36-9mrc"},{"ecosystem":"Packagist","fixed":["1.3.0r4"],"introduced":["1.3.0r1"],"last_affected":[],"package":"pear/auth","purl":"pkg:composer/pear/auth","source":"GHSA-76rh-xv36-9mrc"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2006-0867"},"products":["n/a"],"published":"2006-02-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can falsify authentication credentials in PEAR::Auth library back ends, bypassing security controls and potentially taking over accounts.","url":"https://insights.sbomify.com/CVE-2006-0868/"}