# CVE-2006-0868: PEAR::Auth potential authentication bypass vulnerability

> Remote attackers can falsify authentication credentials in PEAR::Auth library back ends, bypassing security controls and potentially taking over accounts.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2006
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-76rh-xv36-9mrc

## What is CVE-2006-0868?

CVE-2006-0868 is a high-severity authentication bypass vulnerability in n/a, published on 23 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple unspecified injection vulnerabilities in unspecified Auth Container back ends for PEAR::Auth before 1.2.4, and 1.3.x before 1.3.0r4, allow remote attackers to "falsify authentication credentials," related to the "underlying storage containers."

## Which versions are affected by CVE-2006-0868?

4 open source packages ship an affected version, including pear/auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pear/auth` | Packagist | All versions | 1.2.4 |
| `pear/auth` | Packagist | All versions | 1.2.4 |
| `pear/auth` | Packagist | From 1.3.0r1 | 1.3.0r4 |
| `pear/auth` | Packagist | From 1.3.0r1 | 1.3.0r4 |

Products: Pear Xml Rpc.

## How do I fix CVE-2006-0868?

Upgrade pear/auth to a fixed version for your release line: 1.2.4 or 1.3.0r4.

## Is CVE-2006-0868 being exploited?

There is no known exploitation of CVE-2006-0868 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-0868 and fix it if it is affected.

What it is: CVE-2006-0868 is a high-severity authentication bypass vulnerability in n/a, published on 23 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2006-0868 in the wild and no public exploit code.

Affected packages and fixed versions:
- pear/auth (Packagist): affected all versions; fixed in 1.2.4
- pear/auth (Packagist): affected all versions; fixed in 1.2.4
- pear/auth (Packagist): affected from 1.3.0r1; fixed in 1.3.0r4
- pear/auth (Packagist): affected from 1.3.0r1; fixed in 1.3.0r4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-0868/ (Markdown: https://insights.sbomify.com/CVE-2006-0868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-0868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-0868
- OSV: https://osv.dev/vulnerability/CVE-2006-0868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-0868/
Summaries are generated and may contain mistakes; the official description above is the record.
