CVE-2006-0907 SQL injection in n/a

High 7.5 Published Updated

Remote attackers can execute arbitrary SQL commands in PHP-Nuke via encoded comment sequences, bypassing input filters to access or modify database content.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2006-0907?

CVE-2006-0907 is a high-severity SQL injection vulnerability in Francisco Burzi Php-Nuke, published on 28 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SQL injection vulnerability in PHP-Nuke before 7.8 Patched 3.2 allows remote attackers to execute arbitrary SQL commands via encoded /%2a (/*) sequences in the query string, which bypasses regular expressions that are intended to protect against SQL injection, as demonstrated via the kala parameter.

Which versions are affected by CVE-2006-0907?

It affects 1 product.

Products include Francisco Burzi Php-Nuke.

How do I fix CVE-2006-0907?

No fix has been published for CVE-2006-0907 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2006-0907 being exploited?

There is no known exploitation of CVE-2006-0907 in the wild and no public exploit code.

All Francisco Burzi Php-Nuke vulnerabilities

Sources

Also known as GHSA-vc7f-952f-fcmv.

Is CVE-2006-0907 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free