{"answers":{"affected":"2 open source packages ship an affected version, including pear/archive_tar. It affects 1 product.","exploited":"There is no known exploitation of CVE-2006-0931 in the wild and no public exploit code.","fix":"Upgrade pear/archive_tar to 1.3.2 or later.","what":"CVE-2006-0931 is a medium-severity path traversal vulnerability in n/a, published on 28 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2006-0931 and fix it if it is affected.\n\nWhat it is: CVE-2006-0931 is a medium-severity path traversal vulnerability in n/a, published on 28 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2006-0931 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pear/archive_tar (Packagist): affected from 1.2; fixed in 1.3.2\n- pear/archive_tar (Packagist): affected from 1.2; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-0931/ (Markdown: https://insights.sbomify.com/CVE-2006-0931/index.md)","id":"CVE-2006-0931","markdown":"https://insights.sbomify.com/CVE-2006-0931/index.md","name":"CVE-2006-0931","record":{"aliases":["GHSA-f3xw-vgc7-f7h8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Archive_Tar library","requires_auth":"none","summary":"Remote attackers can overwrite arbitrary files via crafted TAR archives, potentially leading to code execution in applications using the vulnerable library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pear_archive_tar","vendor":"pear"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in PEAR::Archive_Tar 1.2, and other versions before 1.3.2, allows remote attackers to create and overwrite arbitrary files via certain crafted pathnames in a TAR archive.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PEAR::Archive_Tar Directory Traversal vulnerability","id":"CVE-2006-0931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2006"},"n_packages":2,"n_references":8,"next":{"headline":"Path traversal in n/a","id":"CVE-2006-0932"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.2"],"introduced":["1.2"],"last_affected":[],"package":"pear/archive_tar","purl":null,"source":"GHSA-f3xw-vgc7-f7h8"},{"ecosystem":"Packagist","fixed":["1.3.2"],"introduced":["1.2"],"last_affected":[],"package":"pear/archive_tar","purl":"pkg:composer/pear/archive_tar","source":"GHSA-f3xw-vgc7-f7h8"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2006-0930"},"products":["n/a"],"published":"2006-02-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can overwrite arbitrary files via crafted TAR archives, potentially leading to code execution in applications using the vulnerable library.","url":"https://insights.sbomify.com/CVE-2006-0931/"}