# CVE-2006-0931: PEAR::Archive_Tar Directory Traversal vulnerability

> Remote attackers can overwrite arbitrary files via crafted TAR archives, potentially leading to code execution in applications using the vulnerable library.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2006
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-f3xw-vgc7-f7h8

## What is CVE-2006-0931?

CVE-2006-0931 is a medium-severity path traversal vulnerability in n/a, published on 28 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in PEAR::Archive_Tar 1.2, and other versions before 1.3.2, allows remote attackers to create and overwrite arbitrary files via certain crafted pathnames in a TAR archive.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2006-0931?

2 open source packages ship an affected version, including pear/archive_tar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pear/archive_tar` | Packagist | From 1.2 | 1.3.2 |
| `pear/archive_tar` | Packagist | From 1.2 | 1.3.2 |

Products: Pear Pear Archive Tar.

## How do I fix CVE-2006-0931?

Upgrade pear/archive_tar to 1.3.2 or later.

## Is CVE-2006-0931 being exploited?

There is no known exploitation of CVE-2006-0931 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-0931 and fix it if it is affected.

What it is: CVE-2006-0931 is a medium-severity path traversal vulnerability in n/a, published on 28 Feb 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2006-0931 in the wild and no public exploit code.

Affected packages and fixed versions:
- pear/archive_tar (Packagist): affected from 1.2; fixed in 1.3.2
- pear/archive_tar (Packagist): affected from 1.2; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-0931/ (Markdown: https://insights.sbomify.com/CVE-2006-0931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-0931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-0931
- OSV: https://osv.dev/vulnerability/CVE-2006-0931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-0931/
Summaries are generated and may contain mistakes; the official description above is the record.
