CVE-2006-10001 Subscribe to Comments Plugin subscribe-to-comments.php cross site scripting

Low 3.5 Published Updated

A cross-site scripting vulnerability in the Subscribe to Comments WordPress plugin allows remote attackers to inject malicious scripts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2006-10001?

CVE-2006-10001 is a low-severity cross-site scripting vulnerability in Subscribe to Comments Plugin, published on 5 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability, which was classified as problematic, was found in Subscribe to Comments Plugin up to 2.0.7 on WordPress. This affects an unknown part of the file subscribe-to-comments.php. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.0.8 is able to address this issue. The identifier of the patch is 9683bdf462fcac2f32b33be98f0b96497fbd1bb6. It is recommended to upgrade the affected component. The identifier VDB-222321 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2006-10001?

It affects 1 product.

Products include Markjaquith Subscribe to Comments.

How do I fix CVE-2006-10001?

No fix has been published for CVE-2006-10001 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2006-10001 being exploited?

There is no known exploitation of CVE-2006-10001 in the wild and no public exploit code.

Sources

Also known as GHSA-pgq7-29r8-3w67.

Is CVE-2006-10001 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free