# CVE-2006-10001: Subscribe to Comments Plugin subscribe-to-comments.php cross site scripting

> A cross-site scripting vulnerability in the Subscribe to Comments WordPress plugin allows remote attackers to inject malicious scripts.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Mar 2023
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-pgq7-29r8-3w67

## What is CVE-2006-10001?

CVE-2006-10001 is a low-severity cross-site scripting vulnerability in Subscribe to Comments Plugin, published on 5 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in Subscribe to Comments Plugin up to 2.0.7 on WordPress. This affects an unknown part of the file subscribe-to-comments.php. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.0.8 is able to address this issue. The identifier of the patch is 9683bdf462fcac2f32b33be98f0b96497fbd1bb6. It is recommended to upgrade the affected component. The identifier VDB-222321 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2006-10001?

It affects 1 product.


Products: Markjaquith Subscribe to Comments.

## How do I fix CVE-2006-10001?

No fix has been published for CVE-2006-10001 yet. Limit exposure of the affected software until one is available.

## Is CVE-2006-10001 being exploited?

There is no known exploitation of CVE-2006-10001 in the wild and no public exploit code.

## Other vulnerabilities in Subscribe to Comments Plugin

- [CVE-2015-10133](https://insights.sbomify.com/CVE-2015-10133/): Subscribe to Comments <= 2.1.2 - Local File Includion (high 7.2)
- [CVE-2024-8792](https://insights.sbomify.com/CVE-2024-8792/): Subscribe to Comments <= 2.3 - Reflected Cross-Site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-10001 and fix it if it is affected.

What it is: CVE-2006-10001 is a low-severity cross-site scripting vulnerability in Subscribe to Comments Plugin, published on 5 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2006-10001 in the wild and no public exploit code.

Affected product: Subscribe to Comments Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-10001/ (Markdown: https://insights.sbomify.com/CVE-2006-10001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-10001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-10001
- OSV: https://osv.dev/vulnerability/CVE-2006-10001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-10001/
Summaries are generated and may contain mistakes; the official description above is the record.
