# CVE-2006-1546: Apache Struts vulnerable to Improper Input Validation

> Remote attackers can bypass input validation in Apache Struts by sending a specific cancel parameter, potentially allowing unauthorized actions.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2006
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-vf8g-mpmw-qv87

## What is CVE-2006-1546?

CVE-2006-1546 is a high-severity vulnerability in Apache Struts, published on 30 Mar 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to bypass validation via a request with a 'org.apache.struts.taglib.html.Constants.CANCEL' parameter, which causes the action to be canceled but would not be detected from applications that do not use the isCancelled check.

## Which versions are affected by CVE-2006-1546?

2 open source packages ship an affected version, including struts:struts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `struts:struts` | Maven | All versions | 1.2.9 |
| `struts:struts` | Maven | All versions | 1.2.9 |

Products: Apache Struts.

## How do I fix CVE-2006-1546?

Upgrade struts:struts to 1.2.9 or later.

## Is CVE-2006-1546 being exploited?

There is no known exploitation of CVE-2006-1546 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-1546 and fix it if it is affected.

What it is: CVE-2006-1546 is a high-severity vulnerability in Apache Struts, published on 30 Mar 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2006-1546 in the wild and no public exploit code.

Affected packages and fixed versions:
- struts:struts (Maven): affected all versions; fixed in 1.2.9
- struts:struts (Maven): affected all versions; fixed in 1.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-1546/ (Markdown: https://insights.sbomify.com/CVE-2006-1546/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-1546
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-1546
- OSV: https://osv.dev/vulnerability/CVE-2006-1546

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-1546/
Summaries are generated and may contain mistakes; the official description above is the record.
