{"answers":{"affected":"2 open source packages ship an affected version, including struts:struts. It affects 1 product.","exploited":"Yes. Attackers have exploited CVE-2006-1547 in the wild since at least 21 Jan 2022.","fix":"Upgrade struts:struts to 1.2.9 or later. US federal agencies must fix it by 21 Jul 2022.","what":"CVE-2006-1547 is a high-severity denial of service vulnerability in Apache Struts, published on 30 Mar 2006. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2006-1547 and fix it if it is affected.\n\nWhat it is: CVE-2006-1547 is a high-severity denial of service vulnerability in Apache Struts, published on 30 Mar 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2006-1547 in the wild since at least 21 Jan 2022.\n\nAffected packages and fixed versions:\n- struts:struts (Maven): affected all versions; fixed in 1.2.9\n- struts:struts (Maven): affected all versions; fixed in 1.2.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-1547/ (Markdown: https://insights.sbomify.com/CVE-2006-1547/index.md)","id":"CVE-2006-1547","markdown":"https://insights.sbomify.com/CVE-2006-1547/index.md","name":"CVE-2006-1547","record":{"aliases":["GHSA-7qwv-cwgj-c8rj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"Remote attackers can cause a denial of service in Apache Struts by sending a crafted multipart form that accesses internal handler methods.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"struts","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-749","name":"Exposed Dangerous Method or Function"}],"description":"ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"exploited"},"has_fix":true,"headline":"Apache Struts 1 ActionForm Denial-of-Service","id":"CVE-2006-1547","indexable":true,"kev":{"dateAdded":"2022-01-21","dueDate":"2022-07-21","knownRansomwareCampaignUse":"Unknown","product":"Struts 1","requiredAction":"Apply updates per vendor instructions.","vendorProject":"Apache","vulnerabilityName":"Apache Struts 1 ActionForm Denial-of-Service Vulnerability"},"kind":"cve","links":{"ecosystem":"Maven","product":"apache:struts","products":["apache:struts"],"type":"denial_of_service","year":"2006"},"n_packages":2,"n_references":9,"next":{"headline":"Cross-site scripting in Apache Struts","id":"CVE-2006-1548"},"packages":[{"ecosystem":"Maven","fixed":["1.2.9"],"introduced":["0"],"last_affected":[],"package":"struts:struts","purl":null,"source":"GHSA-7qwv-cwgj-c8rj"},{"ecosystem":"Maven","fixed":["1.2.9"],"introduced":["0"],"last_affected":[],"package":"struts:struts","purl":"pkg:maven/struts/struts","source":"GHSA-7qwv-cwgj-c8rj"}],"prev":{"headline":"Apache Struts vulnerable to Improper Input Validation","id":"CVE-2006-1546"},"products":["n/a"],"published":"2006-03-30","related":[{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2020-17530","kev_date_added":"2021-11-03","published":"2020-12-11"},{"cvss_score":9.8,"headline":"Apache Struts 1 Improper Input Validation","id":"CVE-2017-9791","kev_date_added":"2022-02-10","published":"2017-07-10"},{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638","kev_date_added":"2021-11-03","published":"2017-03-11"},{"cvss_score":9.8,"headline":"Apache Struts 2 Improper Input Validation","id":"CVE-2012-0391","kev_date_added":"2022-01-21","published":"2012-01-08"},{"cvss_score":8.1,"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776","kev_date_added":"2021-11-03","published":"2018-08-22"},{"cvss_score":8.1,"headline":"Apache Struts Deserialization of Untrusted Data","id":"CVE-2017-9805","kev_date_added":"2021-11-03","published":"2017-09-15"},{"cvss_score":8.1,"headline":"Apache Struts Command Injection","id":"CVE-2016-3081","kev_date_added":"2026-10-08","published":"2016-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"active","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-22","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in Apache Struts by sending a crafted multipart form that accesses internal handler methods.","url":"https://insights.sbomify.com/CVE-2006-1547/"}