# CVE-2006-1547: Apache Struts 1 ActionForm Denial-of-Service

> Remote attackers can cause a denial of service in Apache Struts by sending a crafted multipart form that accesses internal handler methods.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Yes, since 21 Jan 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2006
- **Updated:** 22 Oct 2025
- **Also known as:** GHSA-7qwv-cwgj-c8rj

## What is CVE-2006-1547?

CVE-2006-1547 is a high-severity denial of service vulnerability in Apache Struts, published on 30 Mar 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2006-1547?

2 open source packages ship an affected version, including struts:struts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `struts:struts` | Maven | All versions | 1.2.9 |
| `struts:struts` | Maven | All versions | 1.2.9 |

Products: Apache Struts.

## How do I fix CVE-2006-1547?

Upgrade struts:struts to 1.2.9 or later. US federal agencies must fix it by 21 Jul 2022.

## Is CVE-2006-1547 being exploited?

Yes. Attackers have exploited CVE-2006-1547 in the wild since at least 21 Jan 2022.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-1547 and fix it if it is affected.

What it is: CVE-2006-1547 is a high-severity denial of service vulnerability in Apache Struts, published on 30 Mar 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2006-1547 in the wild since at least 21 Jan 2022.

Affected packages and fixed versions:
- struts:struts (Maven): affected all versions; fixed in 1.2.9
- struts:struts (Maven): affected all versions; fixed in 1.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-1547/ (Markdown: https://insights.sbomify.com/CVE-2006-1547/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-1547
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-1547
- OSV: https://osv.dev/vulnerability/CVE-2006-1547

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-1547/
Summaries are generated and may contain mistakes; the official description above is the record.
