{"answers":{"affected":"2 open source packages ship an affected version, including struts:struts. It affects 1 product.","exploited":"There is no known exploitation of CVE-2006-1548 in the wild and no public exploit code.","fix":"Upgrade struts:struts to 1.2.9 or later.","what":"CVE-2006-1548 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 30 Mar 2006. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2006-1548 and fix it if it is affected.\n\nWhat it is: CVE-2006-1548 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 30 Mar 2006. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2006-1548 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- struts:struts (Maven): affected all versions; fixed in 1.2.9\n- struts:struts (Maven): affected all versions; fixed in 1.2.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-1548/ (Markdown: https://insights.sbomify.com/CVE-2006-1548/index.md)","id":"CVE-2006-1548","markdown":"https://insights.sbomify.com/CVE-2006-1548/index.md","name":"CVE-2006-1548","record":{"aliases":["GHSA-p3vw-fvwx-qcv5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the parameter name in Apache Struts, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"struts","vendor":"apache"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in Apache Struts","id":"CVE-2006-1548","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:struts","products":["apache:struts"],"type":"xss","year":"2006"},"n_packages":2,"n_references":10,"next":{"headline":"Denial of service in n/a","id":"CVE-2006-1549"},"packages":[{"ecosystem":"Maven","fixed":["1.2.9"],"introduced":["0"],"last_affected":[],"package":"struts:struts","purl":null,"source":"GHSA-p3vw-fvwx-qcv5"},{"ecosystem":"Maven","fixed":["1.2.9"],"introduced":["0"],"last_affected":[],"package":"struts:struts","purl":"pkg:maven/struts/struts","source":"GHSA-p3vw-fvwx-qcv5"}],"prev":{"headline":"Apache Struts 1 ActionForm Denial-of-Service","id":"CVE-2006-1547"},"products":["n/a"],"published":"2006-03-30","related":[{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2020-17530","kev_date_added":"2021-11-03","published":"2020-12-11"},{"cvss_score":9.8,"headline":"Apache Struts 1 Improper Input Validation","id":"CVE-2017-9791","kev_date_added":"2022-02-10","published":"2017-07-10"},{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638","kev_date_added":"2021-11-03","published":"2017-03-11"},{"cvss_score":9.8,"headline":"Apache Struts 2 Improper Input Validation","id":"CVE-2012-0391","kev_date_added":"2022-01-21","published":"2012-01-08"},{"cvss_score":8.1,"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776","kev_date_added":"2021-11-03","published":"2018-08-22"},{"cvss_score":8.1,"headline":"Apache Struts Deserialization of Untrusted Data","id":"CVE-2017-9805","kev_date_added":"2021-11-03","published":"2017-09-15"},{"cvss_score":8.1,"headline":"Apache Struts Command Injection","id":"CVE-2016-3081","kev_date_added":"2026-10-08","published":"2016-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the parameter name in Apache Struts, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2006-1548/"}