# CVE-2006-1711: Plone allows remote users to modify arbitrary portraits

> Remote attackers can modify user portraits in Plone due to missing access restrictions on specific methods.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2006
- **Updated:** 7 Aug 2024
- **Also known as:** DSA-1032-1, GHSA-jcwh-rj6j-vm75, PYSEC-2026-733

## What is CVE-2006-1711?

CVE-2006-1711 is a medium-severity missing authorization vulnerability in Plone Plone, published on 11 Apr 2006. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Plone 2.0.5, 2.1.2, and 2.5-beta1 does not restrict access to the (1) changeMemberPortrait, (2) deletePersonalPortrait, and (3) testCurrentPassword methods, which allows remote attackers to modify portraits.

## Which versions are affected by CVE-2006-1711?

7 open source packages ship an affected version, including plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | All versions | None |
| `plone` | PyPI | All versions | None |
| `plone` | PyPI | All versions | 2.0.6 |
| `plone` | PyPI | All versions | 2.0.6 |
| `plone` | PyPI | All versions | 2.0.6 |
| `plone` | PyPI | From 2.1.0 to 2.1.2 | None |
| `plone` | PyPI | From 2.1.0 to 2.1.2 | None |

Products: Plone Plone.

## How do I fix CVE-2006-1711?

Upgrade plone to 2.0.6 or later.

## Is CVE-2006-1711 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-1711 exists.

Public exploit code:

- Plone 2.x - MembershipTool Access Control Bypass (exploitdb)

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-1711 and fix it if it is affected.

What it is: CVE-2006-1711 is a medium-severity missing authorization vulnerability in Plone Plone, published on 11 Apr 2006. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-1711 exists.

Affected packages and fixed versions:
- plone (PyPI): affected all versions; no fix listed
- plone (PyPI): affected all versions; no fix listed
- plone (PyPI): affected all versions; fixed in 2.0.6
- plone (PyPI): affected all versions; fixed in 2.0.6
- plone (PyPI): affected all versions; fixed in 2.0.6
- plone (PyPI): affected from 2.1.0 up to 2.1.2; no fix listed
- plone (PyPI): affected from 2.1.0 up to 2.1.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-1711/ (Markdown: https://insights.sbomify.com/CVE-2006-1711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-1711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-1711
- OSV: https://osv.dev/vulnerability/CVE-2006-1711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-1711/
Summaries are generated and may contain mistakes; the official description above is the record.
