# CVE-2006-2582: Remote code execution in rwiki

> Remote attackers can execute arbitrary Ruby code in RWiki via the editing form, posing a critical risk to web application integrity.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 25 May 2006
- **Updated:** 7 Aug 2024
- **Also known as:** CVE-2006-2594, GHSA-wwmf-6p58-6vj2

## What is CVE-2006-2582?

CVE-2006-2582 is a high-severity code injection vulnerability in n/a, published on 25 May 2006. It can be exploited over the network.

### Official description

The editing form in RWiki 2.1.0pre1 through 2.1.0 allows remote attackers to execute arbitrary Ruby code via unknown attack vectors.

## Which versions are affected by CVE-2006-2582?

2 open source packages ship an affected version, including rwiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rwiki` | RubyGems | From 2.1.0pre1 | 2.1.1 |
| `rwiki` | RubyGems | From 2.1.0pre1 | 2.1.1 |

Products: Rwiki Rwiki.

## How do I fix CVE-2006-2582?

Upgrade rwiki to 2.1.1 or later.

## Is CVE-2006-2582 being exploited?

There is no known exploitation of CVE-2006-2582 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2006-2581](https://insights.sbomify.com/CVE-2006-2581/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-2582 and fix it if it is affected.

What it is: CVE-2006-2582 is a high-severity code injection vulnerability in n/a, published on 25 May 2006. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2006-2582 in the wild and no public exploit code.

Affected packages and fixed versions:
- rwiki (RubyGems): affected from 2.1.0pre1; fixed in 2.1.1
- rwiki (RubyGems): affected from 2.1.0pre1; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-2582/ (Markdown: https://insights.sbomify.com/CVE-2006-2582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-2582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-2582
- OSV: https://osv.dev/vulnerability/CVE-2006-2582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-2582/
Summaries are generated and may contain mistakes; the official description above is the record.
