{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-3668 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2006-3668 is a high-severity memory corruption vulnerability in n/a, published on 17 Jul 2006. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2006-3668 and fix it if it is affected.\n\nWhat it is: CVE-2006-3668 is a high-severity memory corruption vulnerability in n/a, published on 17 Jul 2006. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-3668 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-3668/ (Markdown: https://insights.sbomify.com/CVE-2006-3668/index.md)","id":"CVE-2006-3668","markdown":"https://insights.sbomify.com/CVE-2006-3668/index.md","name":"CVE-2006-3668","record":{"aliases":["DEBIAN-CVE-2006-3668","DSA-1123","GHSA-w57g-v53q-xw44","openSUSE-SU-2024:10729-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"DUMB audio library","requires_auth":"none","summary":"Heap-based buffer overflow in DUMB library allows arbitrary code execution via malicious Impulse Tracker files.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dumb","vendor":"dynamic_universal_music_bibliotheque"}],"cvss":{"score":7.6,"severity":"high","source":"nvd","vector":"AV:N/AC:H/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Heap-based buffer overflow in the it_read_envelope function in Dynamic Universal Music Bibliotheque (DUMB) 0.9.3 and earlier and current CVS as of 20060716, including libdumb, allows user-assisted attackers to execute arbitrary code via a \".it\" (Impulse Tracker) file with an envelope with a large number of nodes.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":1,"first_seen":"2006-07-19","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2006-07-19","kind":"exploitdb","ref":"2037","stars":null,"title":"Dumb 0.9.3 - 'it_read_envelope' Remote Heap Overflow (PoC)"}],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2006-3668","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2006"},"n_packages":1,"n_references":10,"next":{"headline":"Information disclosure in n/a","id":"CVE-2006-3669"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.0.3-1.3"],"introduced":["0"],"last_affected":[],"package":"dumb","purl":"pkg:rpm/opensuse/dumb\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10729-1"}],"prev":{"headline":"Other in n/a","id":"CVE-2006-3667"},"products":["n/a"],"published":"2006-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Heap-based buffer overflow in DUMB library allows arbitrary code execution via malicious Impulse Tracker files.","url":"https://insights.sbomify.com/CVE-2006-3668/"}