# CVE-2006-3933: Alkacon OpenCms XSS via unsanitized message body

> Authenticated users can inject arbitrary scripts via message body in OpenCms, enabling session hijacking or content manipulation.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2006
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-gj9c-69cm-7c37

## What is CVE-2006-3933?

CVE-2006-3933 is a low-severity cross-site scripting vulnerability in n/a, published on 31 Jul 2006. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Alkacon OpenCms before 6.2.2 allows remote authenticated users to inject arbitrary web script or HTML via the message body.

## Which versions are affected by CVE-2006-3933?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 6.2.2 |
| `org.opencms:opencms-core` | Maven | All versions | 6.2.2 |

Products: Alkacon Opencms.

## How do I fix CVE-2006-3933?

Upgrade org.opencms:opencms-core to 6.2.2 or later.

## Is CVE-2006-3933 being exploited?

There is no known exploitation of CVE-2006-3933 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-8811](https://insights.sbomify.com/CVE-2018-8811/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2019-11819](https://insights.sbomify.com/CVE-2019-11819/): Alkacon OpenCMS CSV Injection via New User module (high 7.8)
- [CVE-2005-4475](https://insights.sbomify.com/CVE-2005-4475/): Cross-site scripting in n/a (medium 6.8)
- [CVE-2024-42699](https://insights.sbomify.com/CVE-2024-42699/): OpenCMS Cross-Site Scripting vulnerability (medium 6.5)
- [CVE-2021-3312](https://insights.sbomify.com/CVE-2021-3312/): XML External Entity Reference in org.opencms:opencms-core (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-3933 and fix it if it is affected.

What it is: CVE-2006-3933 is a low-severity cross-site scripting vulnerability in n/a, published on 31 Jul 2006. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2006-3933 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 6.2.2
- org.opencms:opencms-core (Maven): affected all versions; fixed in 6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-3933/ (Markdown: https://insights.sbomify.com/CVE-2006-3933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-3933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-3933
- OSV: https://osv.dev/vulnerability/CVE-2006-3933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-3933/
Summaries are generated and may contain mistakes; the official description above is the record.
