# CVE-2006-3936: Alkacon OpenCms Exposes JSP Source Code

> Authenticated users can read arbitrary JSP source code via path traversal in the editor interface, exposing sensitive application logic.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2006
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-c5vw-342h-x5rx

## What is CVE-2006-3936?

CVE-2006-3936 is a medium-severity path traversal vulnerability in n/a, published on 31 Jul 2006. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

system/workplace/editors/editor.jsp in Alkacon OpenCms before 6.2.2 allows remote authenticated users to read the source code of arbitrary JSP files by specifying the file in the resource parameter, as demonstrated using index.jsp.

## Which versions are affected by CVE-2006-3936?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 6.2.2 |
| `org.opencms:opencms-core` | Maven | All versions | 6.2.2 |

Products: Alkacon Opencms.

## How do I fix CVE-2006-3936?

Upgrade org.opencms:opencms-core to 6.2.2 or later.

## Is CVE-2006-3936 being exploited?

There is no known exploitation of CVE-2006-3936 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-8811](https://insights.sbomify.com/CVE-2018-8811/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2019-11819](https://insights.sbomify.com/CVE-2019-11819/): Alkacon OpenCMS CSV Injection via New User module (high 7.8)
- [CVE-2005-4475](https://insights.sbomify.com/CVE-2005-4475/): Cross-site scripting in n/a (medium 6.8)
- [CVE-2024-42699](https://insights.sbomify.com/CVE-2024-42699/): OpenCMS Cross-Site Scripting vulnerability (medium 6.5)
- [CVE-2021-3312](https://insights.sbomify.com/CVE-2021-3312/): XML External Entity Reference in org.opencms:opencms-core (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-3936 and fix it if it is affected.

What it is: CVE-2006-3936 is a medium-severity path traversal vulnerability in n/a, published on 31 Jul 2006. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2006-3936 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 6.2.2
- org.opencms:opencms-core (Maven): affected all versions; fixed in 6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-3936/ (Markdown: https://insights.sbomify.com/CVE-2006-3936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-3936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-3936
- OSV: https://osv.dev/vulnerability/CVE-2006-3936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-3936/
Summaries are generated and may contain mistakes; the official description above is the record.
