# CVE-2006-4067: Cross-site scripting (XSS) vulnerability in CakePHP

> Remote attackers can inject arbitrary web script or HTML via the URL in CakePHP 404 error pages, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Aug 2006
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2006-4067, GHSA-vc29-mvwv-wpcq

## What is CVE-2006-4067?

CVE-2006-4067 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Aug 2006. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 ("Not Found") error page.  NOTE: some of these details are obtained from third party information.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2006-4067?

2 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cakephp/cakephp` | Packagist | From 1.0.1.2708 | 1.1.7.3363 |
| `cakephp/cakephp` | Packagist | From 1.0.1.2708 | 1.1.7.3363 |

Products: Cakephp Cakephp.

## How do I fix CVE-2006-4067?

Upgrade cakephp/cakephp to 1.1.7.3363 or later.

## Is CVE-2006-4067 being exploited?

There is no known exploitation of CVE-2006-4067 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22727](https://insights.sbomify.com/CVE-2023-22727/): Database Query::offset() and limit() vulnerable to SQL injection in cakephp (critical 9.8)
- [CVE-2020-35239](https://insights.sbomify.com/CVE-2020-35239/): CakePHP allows method override parameters to bypass CSRF checks (high 8.8)
- [CVE-2015-8379](https://insights.sbomify.com/CVE-2015-8379/): CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter (high 8.8)
- [CVE-2019-11458](https://insights.sbomify.com/CVE-2019-11458/): Unsafe deserialization in SmtpTransport in CakePHP (high 7.5)
- [CVE-2016-4793](https://insights.sbomify.com/CVE-2016-4793/): CakePHP allows remote attackers to spoof their IP (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-4067 and fix it if it is affected.

What it is: CVE-2006-4067 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Aug 2006. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2006-4067 in the wild and no public exploit code.

Affected packages and fixed versions:
- cakephp/cakephp (Packagist): affected from 1.0.1.2708; fixed in 1.1.7.3363
- cakephp/cakephp (Packagist): affected from 1.0.1.2708; fixed in 1.1.7.3363

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-4067/ (Markdown: https://insights.sbomify.com/CVE-2006-4067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-4067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-4067
- OSV: https://osv.dev/vulnerability/CVE-2006-4067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-4067/
Summaries are generated and may contain mistakes; the official description above is the record.
