{"answers":{"affected":"2 open source packages ship an affected version, including rails. It affects 2 products.","exploited":"There is no known exploitation of CVE-2006-4111 in the wild and no public exploit code.","fix":"Upgrade rails to 1.1.6 or later.","what":"CVE-2006-4111 is a high-severity code injection vulnerability in Rubyonrails Rails, published on 14 Aug 2006. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2006-4111 and fix it if it is affected.\n\nWhat it is: CVE-2006-4111 is a high-severity code injection vulnerability in Rubyonrails Rails, published on 14 Aug 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2006-4111 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails (RubyGems): affected from 1.1.0; fixed in 1.1.6\n- rails (RubyGems): affected from 1.1.0; fixed in 1.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-4111/ (Markdown: https://insights.sbomify.com/CVE-2006-4111/index.md)","id":"CVE-2006-4111","markdown":"https://insights.sbomify.com/CVE-2006-4111/index.md","name":"CVE-2006-4111","record":{"aliases":["DEBIAN-CVE-2006-4111","GHSA-rvpq-5xqx-pfpp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary Ruby code via a crafted file upload request that modifies the LOAD_PATH variable.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Ruby on Rails before 1.1.5 allows remote attackers to execute Ruby code with \"severe\" or \"serious\" impact via a File Upload request with an HTTP header that modifies the LOAD_PATH variable, a different vulnerability than CVE-2006-4112.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ruby on Rails vulnerable to code injection","id":"CVE-2006-4111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"rubyonrails:rails","products":["rubyonrails:rails"],"type":"code_injection","year":"2006"},"n_packages":2,"n_references":9,"next":{"headline":"Rails Denial of Service vulnerability","id":"CVE-2006-4112"},"packages":[{"ecosystem":"RubyGems","fixed":["1.1.6"],"introduced":["1.1.0"],"last_affected":[],"package":"rails","purl":null,"source":"GHSA-rvpq-5xqx-pfpp"},{"ecosystem":"RubyGems","fixed":["1.1.6"],"introduced":["1.1.0"],"last_affected":[],"package":"rails","purl":"pkg:gem/rails","source":"GHSA-rvpq-5xqx-pfpp"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2006-4110"},"products":["n/a"],"published":"2006-08-14","related":[{"cvss_score":10,"headline":"Active Record contains deserialization of arbitrary YAML","id":"CVE-2013-0277","kev_date_added":null,"published":"2013-02-13"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17916","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17917","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8,"headline":"Rails Active Storage has possible Path Traversal in DiskService","id":"CVE-2026-33195","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch","id":"CVE-2024-26142","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"ReDoS based DoS vulnerability in Action Dispatch","id":"CVE-2023-22792","kev_date_added":null,"published":"2023-02-09"},{"cvss_score":7.5,"headline":"Denial of Service in Action Dispatch","id":"CVE-2021-22902","kev_date_added":null,"published":"2021-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary Ruby code via a crafted file upload request that modifies the LOAD_PATH variable.","url":"https://insights.sbomify.com/CVE-2006-4111/"}