# CVE-2006-4684: Zope allows remote attackers to read arbitrary files

> Remote attackers can read arbitrary files on Zope servers via a crafted reStructuredText csv_table directive, exposing sensitive data.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2006
- **Updated:** 7 Aug 2024
- **Also known as:** DSA-1176-1, GHSA-hm8g-jxjj-gfm3

## What is CVE-2006-4684?

CVE-2006-4684 is a medium-severity path traversal vulnerability in n/a, published on 19 Sep 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The docutils module in Zope (Zope2) 2.7.0 through 2.7.9 and 2.8.0 through 2.8.8 does not properly handle web pages with reStructuredText (reST) markup, which allows remote attackers to read arbitrary files via a csv_table directive, a different vulnerability than CVE-2006-3458.

## Which versions are affected by CVE-2006-4684?

4 open source packages ship an affected version, including zope2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope2` | PyPI | From 2.7.0 to 2.7.9 | None |
| `zope2` | PyPI | From 2.7.0 to 2.7.9 | None |
| `zope2` | PyPI | From 2.8.0 | 2.8.9 |
| `zope2` | PyPI | From 2.8.0 | 2.8.9 |

Products: Zope Zope.

## How do I fix CVE-2006-4684?

Upgrade zope2 to 2.8.9 or later.

## Is CVE-2006-4684 being exploited?

There is no known exploitation of CVE-2006-4684 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2000-0062](https://insights.sbomify.com/CVE-2000-0062/): Zope DTML implementation Improper Authentication (critical 10.0)
- [CVE-2021-32674](https://insights.sbomify.com/CVE-2021-32674/): Remote Code Execution via traversal in TAL expressions (high 8.8)
- [CVE-2000-1211](https://insights.sbomify.com/CVE-2000-1211/): Zope does not properly perform security registration for legacy names (high 7.5)
- [CVE-2002-0170](https://insights.sbomify.com/CVE-2002-0170/): Zope does not properly verify the access for objects with proxy roles (high 7.5)
- [CVE-2002-0688](https://insights.sbomify.com/CVE-2002-0688/): ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-4684 and fix it if it is affected.

What it is: CVE-2006-4684 is a medium-severity path traversal vulnerability in n/a, published on 19 Sep 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2006-4684 in the wild and no public exploit code.

Affected packages and fixed versions:
- zope2 (PyPI): affected from 2.7.0 up to 2.7.9; no fix listed
- zope2 (PyPI): affected from 2.7.0 up to 2.7.9; no fix listed
- zope2 (PyPI): affected from 2.8.0; fixed in 2.8.9
- zope2 (PyPI): affected from 2.8.0; fixed in 2.8.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-4684/ (Markdown: https://insights.sbomify.com/CVE-2006-4684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-4684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-4684
- OSV: https://osv.dev/vulnerability/CVE-2006-4684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-4684/
Summaries are generated and may contain mistakes; the official description above is the record.
